Wärmebrücken- & Dampfdiffusionsbrücken-Programm AnTherm Version 6.115 - 8.133

[ ← ] [ ↑ ] [Inh]

Die Lizenzdatei AnTherm.HID

Die Funktionen des Programms sind durch ein Lizenzierungsverfahren zu aktivieren. Ist das Programm nicht lizenziert, die Lizenzierung noch nicht durchgeführt oder die Lizenz abgelaufen, so ist das Programm nicht funktionstüchtig.

Um die volle Funktionalität des Programms zu aktivieren, muss in AnTherm beim ersten Start der Pfad zur Lizenzdatei AnTherm.HID angegeben werden.

Die Angaben zu der aktuell installierten Programmlizenz und der Lizenzgültigkeit finden Sie in dem Info-Fenster, welches Sie über das Menü Hilfe->Info... erreichen können.

Lizenzierungsverfahren

Das Lizenzierungsverfahren besteht aus 2 Schritten:

  1. Anschaffung der Lizenzdatei
  2. Installation der Lizenzdatei

Anschaffung der Lizenzdatei

Wurde die Aktivierung der Benutzerlizenz noch nicht durchgeführt, so muss die Lizenz-Aktivierung angefordert werden. Sie werden diesbezüglich nach dem Erwerb durch den Lizenzgeber per E-Mail kontaktiert. Probemäßig können Sie AnTherm auch im Demo-Modus betreiben. Verwenden Sie dafür bitte die beim Download von AnTherm zur Verfügung gestellte Demo-Lizenzdatei.

Die Lizenz des Programms ist nicht übertragbar an die physische Geräteidentifikation gebunden (z.B.  einen Hardware-Dongle, eine physische Ethernet-LAN-Netzwerkkarte usw.).
Ein Lizenzschlüssel wird aus

ermittelt.

Installation der Lizenzdatei

Nachdem Sie die Lizenzdatei AnTherm.HID erhalten haben,

  • entpacken Sie die Lizenzdatei aus dem Archiv, falls erforderlich und
  • kopieren Sie die Lizenzdatei ohne Veränderungen in ein Benutzerverzeichnis, einen Public-Folder oder auf ein Netzlaufwerklaufwerk. (Wählen Sie ein beliebiges Verzeichnis, in das Sie auch ohne spezielle administrative Berechtigungen schreiben können.)

Beim erstmaligen Start von AnTherm werden Sie vom Programm aufgefordert, den Pfad zur Lizenzdatei anzugeben. Sie können den Pfad später über die erweiterte Programmeinstellung "Alternative Lizenzdatei AnTherm.HID" oder "Alternative Liste der Lizenzdateien AnTherm.HID" ändern.

Wichtig: Erstellen Sie auch eine Sicherungskopie der personifizierten Lizenzdatei AnTherm.HID, um "im Falle des Falles" diese wiederherstellen zu können.

Falls die Installation auf dem beschriebenen Weg scheitert, können Sie auch die Lizenzdatei Antherm.HID direkt in das Installationsverzeichnis des Programms (typischerweise C:\Programme\tkornicki\AnTherm\ oder C:\Program files\tkornicki\AnTherm\) kopieren.
Wichtig: Benutzen Sie diese Methode bitte nur dann, wenn die Virtualisierung des Installationsverzeichnisses (Standard ab Windows Vista) durch das Erlangen entsprechender administrativer Berechtigung für diesen Kopiervorgang abgeschaltet wurde.

Kundenspezifische Daten (Kunden-Header)

Die kundenspezifischen Daten, bestehend aus vier Textzeilen, werden auf jedem Bericht im Berichtkopf ausgegeben.

Die auf den Ergebnisblättern befindlichen Hersteller- und Anwenderaufdrucke dürfen, entsprechend den Lizenzbedingungen, durch den Lizenznehmer nicht entfernt bzw. verändert werden.

Den genauen Inhalt der vier zur Verfügung stehenden Textzeilen bestimmt der Kunde. Er kann damit z.B. seine Unternehmensbezeichnung, Adresse und andere Angaben in den Kopf eines jeden Ausdruckes einarbeiten. Sie sollten lediglich die Länge der Zeilen so kurz halten, dass die resultierende Ausgabe mit dem mittig auf den Berichten ausgegebenen optionalen kundenspezifischen Logo-Bild nicht überlappt - 50 bis 60 Zeichen pro Zeile sind in den meisten Fällen ausreichend.

Die so aufbereiteten Daten geben Sie dem Lizenzgeber per e-Mail wie folgt bekannt:

Kundendaten (maximal 4 Zeilen jede mit maximal 60 Zeichen): 

Zeile 1: ..............................................

Zeile 2: ..............................................

Zeile 3: ..............................................

Zeile 4: ..............................................

Hardwareidentifikation: ...............................

Die angegebenen Daten sollen wahrheitsgemäß und nachvollziehbar den Nutzungslizenznehmer identifizieren. Der Endkunde ist mit der Darstellung dieser Daten auf dem Informationsbildschirm des Produktes und den Ausdrucken, die durch das Produkt erstellt werden können, einverstanden. Die auf den Ergebnisblättern befindlichen Hersteller- und Anwenderaufdrucke dürfen, entsprechend den Lizenzbedingungen, durch den Lizenznehmer nicht entfernt, versteckt bzw. verändert werden.

Lizenzaktivierung mit dem Hardware-Dongle

Die Aktivierung mit dem Hardware-Dongle bietet die Mobilität der Lizenz zwischen mehreren Rechnern - beachten Sie allerdings die Lizenzbedingungen, welche die Eigentumsrechte regeln und auch die Nutzung jeweils nur an einem Rechner gegebenenfalls erlauben.

DONGLE-Option: ersetzt die Bindung der Lizenz an einen bestimmten Rechner durch die Bindung der Lizenz an mobile Hardware (USB-Dongle) und erlaubt, die Lizenz auf mehreren Rechnern alternierend zu nutzen. DONGLE Option in AnTherm

Anmerkung: Die Hardware-Dongle-Aktivierung ist eine Zusatzoption, welche als Lizenzerweiterung erworben werden kann.

Die Lizenzaktivierung wird mit den Daten des Hardware-Dongles verbunden und in der Lizenzdatei gespeichert. Die Software ist nur dann lauffähig, wenn der zugehörige Hardware-Dongle, welcher auch in der personifizierten Lizenzdatei angegeben ist, in den USB-Port des Rechners gesteckt worden ist.

Vor der Ausführung des Programms stecken Sie den Hardware-Dongle in einen beliebigen USB-Port des Rechners, auf welchem die Software und die zugehörige Lizenzdatei installiert sind. Es ist keine zusätzliche Softwareinstallation (keine Gerätetreiber) für den Einsatz des Dongle mit AnTherm erforderlich.

Wenn Sie den Hardware-Dongle auf einem anderen Rechner einsetzen wollen, speichern Sie zuerst Ihre Anwendungsdaten ab und beenden Sie das Programm. Erst dann stecken Sie den Hardware-Dongle vom Rechner ab.

Anmerkung: Stecken Sie den Hardware-Dongle nie während des Betriebs des Programms ab. Dies kann zum unvorhergesehenen Verhalten des Programms bzw. des Gesamtsystems oder auch zur schweren Beschädigung des Hardware-Dongle selbst führen.

Anmerkung: Schützen Sie den Hardware-Dongle vor Verlust oder Beschädigung, um allfällige Sperr-, Reparatur- oder Ersatzkosten zu vermeiden.

Lizenzaktivierung gebunden an die physische Rechnerhardware eines Rechners

Die Aktivierung der Lizenz gebunden mit einem Rechner gilt nur für diesen einen, durch hardwarespezifische Geräte-Identifikation angegebenen, Rechner - beachten Sie die Lizenzbedingungen, welche die Eigentumsrechte regeln und auch die Nutzung an jeweils nur einem Rechner erlauben.

Die Lizenzaktivierung wird mit den Daten, welche aus dem Info-Fenster bestimmt werden, verbunden und in der Lizenzdatei gespeichert. Die Software ist dann auf dem Rechner lauffähig, der in der personifizierten Lizenzdatei angegeben ist. Im Falle eines Rechnerausfalls oder Rechnerwechsels ist das Lizenzierungsverfahren zu wiederholen -  gegebenenfalls verbunden mit allfälligen Sperr- und Änderungsgebühren.

Senden Sie bitte alle für die Lizenzierung geeigneten Geräte-Identifikatoren des Rechners an den Lizenzgeber direkt aus dem Info-Fenster per e-Mail. Siehe: Info-Fenster.

Manuelles Ersatzverfahren:

In Ausnahmefällen muss auf eine manuelle Ermittlung der Identifikation zurückgegriffen werden. Sollten sich alle übermittelten Daten für das Lizenzierungsverfahren als ungeeignet erweisen, wird auf eine manuelle Identifikation mit Zuhilfenahme der physischen MAC-Adressen aller im Rechner eingebauten Ethernet-Netzwerkkarten zurückgegriffen. Die physische MAC-Adresse einer (oder auch mehrerer) im Rechner eingebauten Ethernet-Netzwerkkarte wird im oberen Teil des Info-Fensters, gleich nach den Lizenzierungsinformationen und den aktiven Lizenzfeatures, aufgelistet:

 

Anmerkung: Das Auslesen der MAC-Adresse ist auch mit Zuhilfenahme eines Hilfsprogramms (adaptersAddresses.exe) möglich (das Programm adaptersAddresses.exe finden Sie im Installationsverzeichnis von AnTherm).

Anmerkung: Das Auslesen der MAC-Adresse ist auch z.B. mit dem Systembefehl "ipconfig /all" möglich. Die mit diesem Programm angezeigte Liste der MAC-Adressen kann allerdings auch Identifikationen von virtuellen Netzwerk-Adaptern beinhalten, welche für die Lizenzierungsidentifikation in AnTherm nicht geeignet sind. Es wird daher empfohlen die Angaben aus dem Info-Fenster oder dem Hilfsprogramm adaptersAddresses.exe zu benutzen.

Demonstrationsmodus

Im Demo-Modus stehen bestimmte Programmfunktionen nicht zur Verfügung. Durch den Erwerb einer permanenten oder zeitlich begrenzten Lizenz kann dieses Verhalten abgeschaltet werden.

Die Lizenzdatei für die Demo-Version befindet sich im Unterverzeichnis "DemoLicense" der Programminstallation.
Die Demo-Lizenz, deren Eigenschaften in der Datei AnTherm.HID im Verzeichnis DemoLicense festgelegt sind, ist auf folgende Programmeigenschaften typischerweise eingeschränkt: RESULTS, SOLVER, 3DIM, 30000CELLS. Zudem kann die Gültigkeit der Lizenz zeitlich begrenzt sein.

  • Im Demo-Modus wird das Infofenster in regelmäßigen Zeitabständen eingeblendet. Dieses muss durch den Benutzer jeweils wieder "weggeklickt" werden.
     
  • Auch die Genauigkeit der Ergebnisse wird im Demonstrationsmodus wesentlich schlechter als erwünscht ausfallen. Im Demonstrationsmodus ist die Konfiguration auf möglichst kleine Rechenzeiten abgestellt, was mit einer Einbuße an Genauigkeit einher geht! Im Demo-Modus ist die Abbruchbedingung (das Delta) auf 10-4 (0.0001) eingestellt; eine höhere (den Normanforderungen entsprechende) Genauigkeit wird jedoch erst ab einer Abbruchbedingung von 10-7 (0.0000001) erreicht.
    Es ist daher nicht sinnvoll, die Ergebnisse der Demo-Version physikalisch interpretieren zu wollen! Eine entsprechende Warnmeldung wird angezeigt, wenn der Benutzer eine genauere Rechnung mittels Verkleinerung der Abbruchbedingung zu erreichen versucht:
Die Abbruchbedingung (Delta) der Lösungsengine wurde auf 0,0001 zurückgesetzt.
Die Demonstrationslizenz ist auf geringe Rechenzeiten optimiert. 
Die Ergebnisse werden zwar schneller aber möglicherweise ungenau bestimmt.
Sie müssen die Lizenz erweitern, um genauere Ergebnisse erhalten zu können.
Nehmen Sie bitte Kontakt mit dem Softwarehersteller oder Wiederverkäufer 
dieser Anwendung auf, um eine Volllizenz zu erwerben.

Anmerkung: Sollte die Gültigkeit der Demo-Lizenz nicht mehr gegeben sein (eine Demonstrationslizenz ist mit Ablaufdatum versehen), verkürzen sich die Zeitabstände, in welchen das Infofensters hervorgehoben wird, mit jeder Anzeige, und das Programm wird nach ca. 5 Minuten beendet.

Anmerkung: Projekte merken, dass sie im Demo-Modus laufen (DemoModeApplied). Nach dem Lizenzupgrade wird die Abbruchbedingung wieder normal gestellt (SolverParameters.DemoModeRevertToNormal).

Features

Welche Funktionsausprägung in Ihrer Lizenz aktiv ist, wird durch folgende Feature-Einträge in der Lizenzdatei festgelegt:

  • 2DIM – die Berechnung von 2-dimensionalen Konstruktionen (2D)
  • 3DIM – die Berechnung von 3-dimensionalen Konstruktionen (multi-Layered oder 3D)
    (ohne 3D-Lizenz keine 3D-Bearbeitung: Abgeschalteten Menus: File->New, File->Convert, File->Import, kein Speichern vom 3D/3DS)
  • RESULTS – das Ausführen des Menüpunktes Results…
  • EDURESULTS – das Ausführen des Menüpunktes Results… mit Wassermarkierung/Wassermarke/Wasserzeichen "Educational"
  • DEMORESULTS – das Ausführen des Menüpunktes Results… mit Wassermarkierung/Wassermarke/Wasserzeichen "Demonstration"
  • SOLVER – das Ausführen des Solvers
  • 10000CELLS – das Ausführen des Solvers bis 10.000 Zellen
  • 30000CELLS – das Ausführen des Solvers bis 30.000 Zellen
  • 50000CELLS – das Ausführen des Solvers bis 50.000 Zellen
  • 100000CELLS – das Ausführen des Solvers bis 100.000 Zellen
  • 300000CELLS – das Ausführen des Solvers bis 300.000 Zellen
  • 1000000CELLS – das Ausführen des Solvers bis 1.000.000 Zellen
  • ANYCELLS – das Ausführen des Solvers ohne Zellenlimit
  • VERSION201309 – befähigt zur Ausführung der des Programms ab Version 7.124
  • NODEMOPOPUP – ermöglicht das Unterdrücken des minütlichen PopUps des Info-Fensters in einer Demo-Lizenz.

DAMPF-Option spezifische Features:

  • DAMPF2DIM - das Lösen der Aufgabe der zweidimensionalen Wasserdampf-Diffusion
  • DAMPF3DIM - das Lösen der Aufgabe der dreidimensionalen Wasserdampf-Diffusion

HARMONIC/TRANSIENT-Option spezifische Features:

Weitere Features:

  • MULTICORE - zur Leistungssteigerung können u.A. folgende Aufgaben auf mehreren Prozessoren oder Prozessorkernen verteilt ausgeführt werden:
    • Lösen des/der Gleichungssysteme - Solver
    • Einlesen der Lösungsvektoren von Dateien im Simulationsverzeichnis
    • Kombination der stationären und harmonischen Lösungsvektoren bei spezifischen Randbedingungen (die Superposition)
    • Harmonische Fourier-Analyse und Synthese der periodischen Randbedingungen
    • Fourier-Synthese von zeitabhängigen Lösungen
    • Erstellen der Ergebnisdaten für die 3D-Visualisierung (Primär- und Sekundärfunktionen), Zeitlinien und Animationen
  • STEREO3DVIEW - erlaubt binokulare 3D-Darstellungen


Folgendes gilt lediglich für den Lizenzgeber und Ersteller einer Lizenzdatei:

  • Ergebnisse sind zugelassen, wenn eines der folgenden Features gegeben ist: RESULTS, EDURESULTS, DEMORESULTS
    Es wird nur eines dieser Features vergeben!
  • Watermarks werden angezeigt (Berichte und Bilder) wenn
    • Demo-License oder 
    • EDURESULTS oder
    • DEMORESULTS Feature vorhanden ist.
  • DAMPF3DIM macht nur mit 3DIM Sinn.
  • 3DIM mit DAMPF2DIM kombiniert erlaubt lediglich die 3D- (oder 3DS-) Eingabe der μ-Werte, aber keine Berechnung/Auswertung der dreidimensionalen Dampfdiffusion (nur zweidimensional möglich).
  • TRANSIENT macht nur mit HARMONIC Sinn.
  • Multi-Host Lizenzierung ist über Zugabe weiterer Feature-Codes in der Form NN-NN-NN-NN-NN-NN möglich. Damit erlangt eine Lizenzdatei die Gültigkeit für mehrere physischen Netzwerkadapter und somit auch für mehrere Rechner. Licensed-Host-Eintrag wird bei Multi-Host-Featurenutzung mit ungültigem Inhalt belegt (lediglich wegen Lesbarkeit, z.B. MU-LT-IH-OS-TS).
  • HARMONIC-Feature - erlaubt Erzeugung einer Rasterdatei welche mit iwaebru kompatibel ist (beinhaltet neben modifiziertem Header auch Rho und Ce).
  • Ab der Version 6.103 (6.103, 2011.11.15) ist das Feature INSTATIONARY obsolet (entspricht nun HARMONIC).
  • Ab der Version 6.103 (6.103, 2011.11.15) ist das Feature FULL obsolet (war ein Kürzel für: 3DIM, RESULTS, SOLVER, ANYCELLS).
  • Ab der Version 6.113 (6.113, 2012.11.01) ist das Feature VERSION201211 für die Ausführung des Programms eine unbedingt notwendige Voraussetzung.
    Ab der Version 6.89 (6.89, 2010.08.02) das Feature VERSION201009 (nun obsolet). Ab der Version 5.82 (5.82, 2010.01.10) das Feature VERSION201001 (nun obsolet). Ab der Version 4.66 (4.66, 2008.11.26) das Feature VERSION200811 (nun obsolet). Ab der Version 3.58 (3.59, 2007.05.08) das Feature VERSION2008 (nun obsolet). Ab der Version 2 (2.45, 2007.02.03) das Feature VERSION2007 (nun obsolet).
  • Die Lizenzdatei ist ab der Version 2.46 (2007.04.21) mit einer Signatur asymmetrisch signiert, wodurch Übertragungsfehler dieser Datei ausgeschlossen werden können.

Wasserdampf-Diffusionsaufgabe (DAMPF-Option)

DAMPF-Option: Die Analyse der mehrdimensionalen Wasserdampf-Diffusionsvorgänge ist nur mit der DAMPF-Option des Programms möglich..

 

Siehe auch: Installation des Programms, Lizenzbedingungen, Systemvoraussetzungen, Lizenz-Anforderungsformular, Programmeinstellung "Alternative Lizenzdatei AnTherm.HID" diesen Speicherort, "Alternative Liste der Lizenzdateien AnTherm.HID"

 

"Educational" Wassermarkierung (Wassermarke, Wasserzeichen)

 

"Demonstration" Wassermarkierung (Wassermarke, Wasserzeichen)

 


 Wärmebrücken in 2D und 3D berechnen und untersuchen mit AnTherm®  

[ ← ] [ ↑ ] [Inh

 Copyright © Kornicki Dienstleistungen in EDV & IT

2017-03-22 12:04 +0100